Companies & CRM Pages Not Loading
Incident Report for Vendasta
Resolved
The issue has been resolved. The Companies and Contacts page are fully operational once more.
Posted Sep 03, 2024 - 20:11 UTC
Identified
We are currently experiencing an issue where the Companies & Contacts pages are not loading. Our development team is currently looking into this issue and we will provide an update once we have more information.
Posted Sep 03, 2024 - 19:24 UTC
This incident affected: Partner Center.