Retail Subscriptions Can Not Be Edited

Incident Report for Vendasta

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 14:42 UTC

Update

The technical team has rolled back their recent changes. Users are now able to edit retail subscriptions once more.
Posted Feb 03, 2026 - 14:42 UTC

Investigating

Our technical team is investigating an issue where, when a user tries to edit a retail subscription, the side panel that populates is completely blank.
There is currently no workaround for this issue at this time.
Further updates will be provided as they develop.
Posted Feb 03, 2026 - 14:09 UTC
This incident affected: Partner Center.