SSL Handshake Failure on CDN-Connected Sites
Incident Report for Vendasta
Resolved
The SSL handshake issue affecting websites connected to our CDN has been fully resolved. Our team identified the root cause and implemented a solution to restore normal operations. All affected sites should now be accessible without any SSL/TLS errors.

We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve the issue. If you continue to experience any problems, please reach out to our support team.

Thank you for your understanding.
Posted Sep 03, 2024 - 16:50 UTC
Identified
Some users may experience issues accessing websites connected to our CDN due to an SSL handshake failure. Affected users might see SSL/TLS-related errors when trying to load these sites. Our engineering team is actively working to identify the root cause of the handshake failures and implement a solution. We will provide updates as soon as more information becomes available.
Posted Sep 03, 2024 - 13:16 UTC
This incident affected: Website Pro.